Freitag, der Dreizehnte…

Beliebige Wochentag / Tag – Kombination
in einem Zeitraum zählen

In einem beliebigen festzulegenden Zeitraum sollen bestimmte Kombinationen von Wochentag und Tag (des Monats) gezählt werden. Die wohl am meisten verwendete Kombination ist wohl Freitag, der Dreizehnte, der angebliche Unglückstag. Bei der Gelegenheit: Diese Zuordnung stimmt nicht; mein Ältester ist an einem Freitag, 13. wie alt geworden? Richtig. 13. 😛 Aber selbstredend kann auch jede andere Kombination berechnet werden.

Zwei Möglichkeiten ohne VBA will ich Ihnen hier vorstellen. Als Vorbereitung schreiben Sie (beispielsweise) in A1 das Startdatum und füllen die Spalte bis zum Enddatum aus. Wie Sie das machen, überlasse ich Ihnen. Ich mache das so, wie hier im Blog beschrieben.

▲ nach oben …

Die drittbeste Lösung

Vorab angemerkt: Die Wertung, welche Lösung sich als besser darstellt, ist natürlich sehr subjektiv. Denn wenn Sie lieber einen verständlichen Weg vorziehen, dann kann dieser hier vorgestellte Weg für Sie die beste sein.

In Spalte A stehen die gesammelten kalendarischen Daten, beginnend in A1. In B1 tragen Sie nun diese Formel ein: =N(UND(WOCHENTAG(A1)=6; TAG(A1)=13))

Das Ergebnis ist 0 oder 1, je nachdem ob es sich um die gesuchte Kombination handelt oder nicht.  Per Doppelklick auf das Ausfüllkästchen wird die Formel bis zur letzten Zeile der Daten in der daneben stehenden Spalte hinunter kopiert. Nun brauchen Sie nur die Summe zu berechnen. Angenommen, das Startdatum ist der 13. September 1978 und heute (09. September 2015) ist das Enddatum, dann wäre das Ergebnis 65. Hier ist es per Filterung möglich, nur die „betroffenen“ Daten anzeigen zu lassen. Das ist ein Vorteil gegenüber dem folgenden Ansatz.

▲ nach oben …

Die zweitbeste Lösung

Es bleibt dabei, dass Spalte A mit den Daten ausgefüllt ist. Und es bleibt auch beim Anfangs- und Endedatum aus dem Beispiel hierüber. Nur die Spalte B bleibt leer. Nun schreiben Sie in eine beliebige Zelle diese Formel: 
=SUMMENPRODUKT((TAG(A1:A13515)=13)*(WOCHENTAG(A1:A13515)=6))
wobei Voraussetzung ist, dass in A13515 das Datum 09.09.2015 steht. Hier ist bei Bedarf eine Anpassung erforderlich. Und das Ergebnis steht sofort sichtbar, 65 Tage.

▲ nach oben …

Die (wohl) beste Lösung

VBA ist das Schlüsselwort. Ein Klick auf eine Schaltfläche, Eingabe von Start und Ende und ruck zuck steht das Ergebnis in einer Textbox, nachdem Sie die Berechnung angestoßen haben. Das Makro erledigt die Arbeit für Sie. Und auf Wunsch wird auch das Ergebnis, alle 65 Daten in Spalte A geschrieben. 

Die Einschränkung „(wohl) beste Lösung“ beruht auf zwei Fakten: Erstens versteht nicht jeder VBA bzw. darf es in manchen Betrieben nicht eingesetzt werden. Und zweitens ließe sich der Code durchaus optimieren.aber hier ist es mir wichtiger, dass auch Einsteiger die Chance haben, das Programm (halbwegs) nachvollziehen zu können. Die Unterschiede wären mess- aber kaum merkbar. In dieser Datei ist alles vorbereitet, Sie brauchen nur noch zu testen.  😎 

▲ nach oben …

Dieser Beitrag wurde unter Datum und Zeit, Mit VBA/Makro, Ohne Makro/VBA abgelegt und mit , , , , , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.