SUMMEWENN() – Funktion

Die Mathematik-Funktion SUMMEWENN()

Beschreibung

Mit der Funktion SUMMEWENN() können Sie jene Werte in einem benannten Bereich addieren, welche den angegebenen Kriterien entsprechen. Wenn Sie beispielsweise in einer Spalte mit Zahlen nur die Werte addieren möchten, die größer als 5 sind, können Sie die folgende Formel verwenden: =SUMMEWENN(B2:B25; ">5")

Syntax

=SUMMEWENN(Bereich; Kriterium; [SummeBereich])

Argument(e)

Das Argument Bereich muss eingegeben werden. Es definiert den Zellbereich, welcher nach dem Kriterium durchsucht wird, der entsprechend ausgewertet werden soll.

Auch der Parameter Kriterium ist erforderlich. Hier wird angegeben, wonach Bereich durchsucht werden soll. Etwas weiter unten finden Sie hierzu wichtige Hinweise.

SummeBereich ist prinzipiell optional aber dann erforderlich, wenn nicht Bereich (das erste Argument) sondern ein anderer Bereich summiert werden soll. Wird dieses Argument nicht angegeben, wann wird Bereich als Basis für die Addition genutzt.

▲ nach oben …

Argument Bereich

Der angegebene Bereich muss zusammenhängend sein und er kann eine beliebige Größe haben. Sie können einen Bereichsnamen verwenden, solange dieser auch einen Bereich ohne „Lücken“ bzw. Unterbrechungen darstellt. Leere Felder sind jedoch erlaubt. Es müssen nicht nur Zahlen enthalten sein, Texte werden für die Suche auch berücksichtigt.

▲ nach oben …

Argument Kriterium

Auch wenn es in Ausnahmefällen ‚ohne‘ geht, sollten Sie immer das Kriterium (oder die einzelnen Elemente des Kriteriums) in Anführungszeichen ("") setzen. Reine Zahlen können zwar auch ohne die Anführungen verwendet werden, aber wenn Sie sich angewöhnen, grundsätzlich mit den „Gänsefüßchen“ zu arbeiten, brauchen Sie sich keine Ausnahmen zu merken.

Prinzipiell geht jede beliebige Kombination von Kriterien, die ein "=", "<", ">", "<>", "<=" oder ">=" enthalten. Einige Beispiele seien hier aufgeführt, weitere finden Sie in dieser Datei Tabellenblatt Summewenn():

  • "=3" → (Bei dieser Ausnahme würde auch nur die 3 ohne Anführungszeichen reichen)
  • "<6,758"
  • ">= 12"
  • "<>PI()" → (Funktioniert, da PI() eine Zahl darstellt
  • "=C5" -> (Geht nicht, selbst wenn in C5 ein Zahlenwert steht.
  • HEUTE() → (Funktioniert, da hier auch eine Zahl dahinter steckt.)
  • "Obst" → (Als Suchkriterium OK, sinnvoll, wenn in einer anderen Spalte die zu summierenden Zahlen stehen.)

▲ nach oben …

Argument SummeBereich

Wenn Sie einen anderen Berich summieren wollen als jenen, wo die Suchkriterien stehen, geben Sie hier den entsprechenden Bereich an. Grundsätzlich wird Bereich von der ersten Zeile an durchsucht; bei einem Treffer wird die gleiche Position in SummeBereich der bisherigen Summe zugeschlagen, sofern es sich um eine Zahl oder einen zum numerischen Wert umwandelbaren Wert handelt. Die Bereiche sollten, müssen aber nicht die gleiche Größe haben. In dem letztgenannten Fall kann es aber dazu führen, dass eine Neuberechnung des Arbeitsblattes erheblich länger dauert als gewöhnlich.

Hinweis: Eine als Suchkriterien angegebener Text (Zeichenfolge) darf die Platzhalterzeichen Fragezeichen ?  und Sternchen * enthalten. Je ein Fragezeichen ersetzt genau ein Zeichen; ein Sternchen ersetzt eine beliebige Zeichenfolge. Wenn Sie nach einem Fragezeichen oder Sternchen als solches suchen möchten, müssen Sie eine Tilde ~ vor dem zu suchenden Zeichen eingeben. Es wird nicht zwischen Groß- und Kleinschreibung unterschieden.

▲ nach oben …

Dieser Beitrag wurde unter Excel-Funktionen, Rechnen & Zahlen abgelegt und mit , , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.