WENNN()-Funktion, Ergebnis = „FALSCH“

Unerwartetes  Ergebnis bei WENN()-Funktion

Manch ein Anwender wundert sich, dass eine scheinbar korrekt eingegebene WENN()-Funktion unter gewissen Umständen ein Ergebnis zurück gibt, welches nun absolut nicht stimmt: FALSCH. Und bei genauerem Hinsehen ist auch klar, dass das immer genau dann geschieht, wenn die Bedingung nicht zutrifft.

Folgende Aufgabe sei gegeben: In A3 soll OK ausgegeben werden, wenn der Wert in A1 größer ist als in A2. Wenn ich das absolut, also wortwörtlich genommen genau so in eine Excel-Funktion umsetze, dann sieht die Funktion so aus:

Die Bedingung trifft zu. Das Ergebnis ist so, wie gewünscht.

Die Bedingung trifft zu. Das Ergebnis ist so, wie gewünscht.

Keine Frage, A1 ist größer als A2 und es wird auch OK als Ergebnis der Funktion ausgegeben. Wenn aber der Wert in A1 nicht größer (oder gleich) dem Wert in A2 ist, dann …

Das Ergebnis ist ein Wahrheitswert, und das soll nicht so sein …

Das Ergebnis ist ein Wahrheitswert, und das soll nicht so sein …

… dann kommt es zu diesem Phänomen. Beachten Sie, dass die Formel in beiden Fällen identisch ist. Und da es zu keiner Fehlermeldung nach Eingabe der Formel kommt, muss diese eigentlich auch fehlerfrei sein. Sonst hätte Excel ja „gemeckert“.

Na ja, Excel akzeptiert diese formal nur halb richtige Funktion. Zur Erinnerung hier den Aufbau eines WENN()-Konstrukts: WENN(Bedingung; Dann-Wert; Sonst-Wert). Hier ist das Ganze noch etwas ausführlicher beschrieben. Wenn Sie nun die obige Funktion analysieren dann werden Sie erkennen, dass der Sonst-Teil fehlt. Die Forderung wurde ja wörtlich genommen und genau so in eine Funktion bzw. Formel übernommen. WENN(Bedingung; Dann schreibe OK in die Zelle. Von Sonst ist hier nichts geschrieben.

Excel sieht nun, dass die Bedingung zutrifft (obere Abbildung) und schreibt OK in die Zelle. Oder aber die Bedingung trifft nicht zu, wie in der unteren Abbildung. Dann „sagt“ Excel, die Bedingung ist nicht erfüllt, denn ein =A!>A2 ergibt nun einmal den logischen Wert, den Wahrheitswert FALSCH.

Und wie wäre es richtig? Eigentlich logisch, ich muss in die Funktion noch hineinschreiben, was in der Zelle stehen soll, wenn die Bedingung nicht zutrifft. Offensichtlich soll dort dann nichts drin stehen, und das „sagen“ wir der Funktion so:

=WENN(A1>A2; „OK“; „“)

So ist die Formel richtig

So ist die Formel richtig

Die beiden Anführungszeichen im Dann-Teil machen es aus. Für „Normalanwender“ war’s das auch schon. Wenn Sie allerdings etwas mehr in die Tiefen des Excel einsteigen, dann heißt es: Aufgepasst! Kein sichtbarer Inhalt einer Zelle heißt noch lange nicht, dass da nichts drin steht! Sehen Sie sich einfach einmal die folgende Abbildung in Ruhe an:

Nichts sehen heißt nicht "Nichts drin"!

Nichts sehen heißt nicht „Nichts drin“!

Falls Sie mit der Zelle A3 als Referenz in einer weiteren WENN()-Funktion arbeiten wollen, dann ist es schon wichtig, worauf Sie prüfen. Ich habe Ihnen einmal in Spalte B drei verschiedene Funktionsergebnisse hin geschrieben und in Spalte C die dazu gehörigen Funktionen (als Text). Ziehen Sie Ihre Schlüsse selbst …

Ach ja, noch eines sei hier allen experimentierfreudigen Usern gesagt: So richtig fies wird es, wenn Sie die Funktion so eingeben, also mit einem zweiten Semikolon für den Sonst-Teil, welcher aber ohne Inhalt ist:

=WENN(A1>A2; "OK";)

und dann A3 mit einem Zahlenformat 0;0; versehen (beachten Sie das 2. Semikolon!). Die Zelle erscheint dann leer, enthält keinen Text und ist auch nicht leer. Solche Konstrukte können Kollegen zum Wahnsinn treiben.  👿 

▲ nach oben …

[whohit]T&T, FN: WENN(), Ergebnis FALSCH[/whohit]

Dieser Beitrag wurde unter Allgemein veröffentlicht. Setze ein Lesezeichen auf den Permalink.