Ziffern (Text) zu Zahlen

Insbesondere durch einen Import kann es vorkommen, dass Ziffernfolgen als Text in einer Zelle stehen. Und wenn dann auch noch die Ausrichtung rechtsbündig ist, fällt das gar nicht auf. Denn Excel kann in den meisten Fällen durchaus mit den Werten rechnen.

„Interessant“ wird es erst, wenn diese Werte sortiert werden sollen. Angenommen, dort stehen die Text-Werte 1, 3, 6, 9, 12, 15, 25, 30 drin, dann wird Excel aller Voraussicht nach so „sortieren“: 1, 12, 15, 25, 3, 30. Also zuerst nach dem ersten Zeichen, dann nach dem zweiten. Dass es sich dabei um Ziffern handelt, ist in diesem Fall nicht relevant.

Die Lösung ist in solchen Fällen vielfach sehr einfach:

  • Markieren Sie die ganze Spalte oder den betroffenen Bereich der Spalte
  • (Menü) Daten | Text in Spalten
  • Sofort auf Fertig stellen klicken.

Hinweis: Das funktioniert aber nur, wenn das Zahlenformat der Zellen nicht Text ist. Und es darf (natürlich) keine Formel in der Zelle stehen, denn diese ist zwar dem Aussehen nach Text aber gibt normalerweise Ziffern und Trennzeichen als Zahl zurück.

Alternative: Geben Sie in einer Hilfsspalte diese Formel ein: =WERT(A1) und kopieren Sie die Ergebnisse als Wert in die Ursprungsspalte. Wenn in dem markierten Bereich auch Texte vorkommen können, die nicht als Zahl interpretiert werden können, dann bietet sich folgende Formel an: =WENN(ISTZAHL(A1); WERT(A1); A1). Und falls Ihr Excel die Funktion ISTZAHL() noch nicht kennt, bliebe beispielsweise diese Möglichkeit einer Formel: =WENN(ISTFEHLER(WERT(A1)); A1; WERT(A1)).

Eine weitere Möglichkeit: Geben Sie in eine beliebige, als Standard formatierte Zelle eine 1 ein. Kopieren Sie diesen Wert beispielsweise per StrgC in die Zwischenablage. Markieren Sie den umzuwandelnden Bereich und über das Menü Einfügen oder mittels Rechtsklick den Punkt Inhalte einfügen, bei Vorgang den Punkt Multiplizieren aktivieren und anschließend OK.

Dieser Beitrag wurde unter Allgemein, Fehlerbehandlung, Formatierung, Rechnen & Zahlen, Text, Tipps und Tricks abgelegt und mit , , , , , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.