#DIV/0! – Fehler

Auf der Suchen nach #DIV/0!

Immer wieder „beliebt“ bei Usern aller Klassen: Der #DIV/0! – Fehler. Er entsteht, weil Excel zu Recht moniert, dass eine Zahl per Definition nicht durch null geteilt werden darf. So richtig gemein an diesem Fehler ist, dass Excel leere Zellen als null wertet und es auch so zu diesem Fehler kommt.

Es stellt sich die Frage, wie ich so etwas verhindern kann. So ironisch, wie es vielleicht klingt: Aufpassen! Das ist die erste Pflicht eines Excel-Anwenders. Wenn ich also sehe, dass die Möglichkeit besteht, durch null zu dividieren, dann … Ja, was dann? Wenn es klar ist, dass die Zelle leer ist oder eine 0 enthält, dann lasse ich die Division ganz sein. Aber wenn ich beispielsweise auf eine berechnete Zelle zugreife und die entfernte Möglichkeit besteht, dass dort einmal null als Ergebnis heraus kommt, dann werde ich anders vorgehen.

Angenommen, ich will A1 durch A2 teilen, dividieren. Und A2 ist eine Formel, die vielleicht einmal 0 oder ein leeres Feld als Ergebnis bringen kann. Dann gestalte ich die Divisionsfunktion so:

=WENN(ISTFEHLER(A1/A2); „“; A1/A2)

Damit bleibt dann beoi einem Fehler (egal welcher Art) die Ergebniszelle leer. Möchten Sie statt einer leeren Zelle einen eher harmlosen Text statt der Fehlermeldung schreiben wollen, dann könnte das so aussehen:

=WENN(ISTFEHLER(A1/A2); „Bitte prüfen!“; A1/A2)

oder falls Ihnen das Ergebnis 0 lieber ist, dann sieht die Funktion so aus:

=WENN(ISTFEHLER(A1/A2); 0; A1/A2)

Wobei das Ergebnis dann natürlich völliger Unsinn ist, ∞ (unendlich) würde dem eigentlichen Ergebnis wohl am nächsten kommen.  Ich habe mehrfach das Problem so gelöst:

=WENN(ISTFEHLER(A1/A2); -0,0001; A1/A2)

Die Ergebniszelle habe ich dann in folgendem Standard-Zahlenformat darstellen lassen:


So lässt sich eine negative Null darstellen

So lässt sich eine negative Null darstellen.

Damit erreiche ich folgendes:

  • Wegen der 2 Nachkommastellen wird die Zahl gerundet angezeigt.
  • Da nur die Anzeige geändert wird, ist es nach wie vor eine negative Zahl
  • Negative Zahlen werden in rot dargestellt
  • Es wird nun eine rote, negative Null angezeigt, und das fällt dann hoffentlich auch jedem auf.  😎 

Bedenken Sie aber bitte folgendes: Wenn Sie mit dem Ergebnis weiter rechnen wollen, dann müssen Sie unbedingt dieses Ergebnis mit einer WENN()-Funktion abfangen, sonst stimmt ja gar nichts mehr.

▲ nach oben …

Dieser Beitrag wurde unter Fehlerbehandlung, Verschiedenes veröffentlicht. Setze ein Lesezeichen auf den Permalink.