ODER() – Funktion

Die Logik-Funktion ODER()

Beschreibung

Diese Funktion liefert den (logischen) Wert WAHR, wenn eines der übergebenen Argumente als WAHR bewertet wird. Werden alle Argumente als FALSCH (also nicht WAHR) bewertet, liefert die Funktion den (logischen) Wert FALSCH zurück.

Syntax

=ODER(Argument_1; [Argument_2]; [Argument_n])

Argument(e)

Argument_1 ist ein erforderlicher Ausdruck, der entweder mit WAHR oder FALSCH bewertet werden kann.

Argument_1 .. Argument_n ist jeweils ein optionaler Ausdruck, der entweder mit WAHR oder FALSCH bewertet werden kann.

Die Funktion ODER wird immer dann angewendet, wenn mindestens eines von mehreren Argumenten (Bedin­gun­gen) zutreffen muss, um bei entsprechendem Ergebnis eine Entscheidung zu treffen. ODER() wird häufig in Kombination mit WENN() verwendet, um den Nutzen dieser Funktion zu erhöhen. So kann beispielsweise abgefragt werden, ob A1 oder B1 größer ist als 1000. Die reine ODER()-Funktion sähe dann so aus:

=ODER(A1>1000; B1>1000)

und würde dann WAHR oder FALSCH als Ergebnis zurück geben, je nach Größe der Zahlen. In der Mappe Logik.xlsx im Blatt ODER() sind dazu Beispiele aufgeführt. – Wollen Sie einen Text als Funktionsergebnis erhalten, dann ist zusätzlich das WENN() gefragt. Das könnte dann so aussehen:

=WENN(ODER(A1>1000; B1>1000); „OK“; „Nicht OK“)

Selbstverständlich kann das ODER() auch mit anderen Funktionen verknüpft werden, die Logische Bedingungen auswerten.

Hinweise

  • Es können bis zu 255 Argumente innerhalb der ODER()-Funktion verwendet werden.
  • Die Argumente müssen als WAHR oder FALSCH ausgewertet werden können.
  • Auch wenn alle Argumente ein WAHR ergeben, wird WAHR zurück gegeben.
  • Kann eines der Argumente nicht so ausgewertet werden, dass WAHR oder FALSCH zurück gegeben würde, dann wird der Fehlerwert #WERT! zurück gegeben.
  • Enthält ein Argument bzw. ein dort angegebener Bereich Text oder leere Zellen, dann wird der entsprechende Bereich ignoriert, also nicht ausgewertet.

Beachten Sie bitte, dass die Syntax, die Schreibweise in der Funktion eine andere ist als in der Umgangssprache.

Immer wieder kommt es vor, dass die Funktion ODER() mit der Funktion UND() ver­wech­­selt wird, weil diese beiden Worte umgangssprachlich anders gebraucht werden. Das führt dann natürlich zu falschen Ergebnissen. Sehen Sie in diesem Beitrag die Infor­ma­ti­o­nen zur UND()-Funktion, um den Unterschied zu erkennen.

▲ nach oben …

Hat Ihnen der Beitrag gefallen?
Erleichtert dieser Beitrag Ihre Arbeit?

Dann würde ich mich über einen Beitrag (z.B. 1,00€) Ihrerseits freuen …

Dieser Beitrag wurde unter Excel-Funktionen abgelegt und mit , , , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.